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Guide d’utilisation d’Igor Pro pour le 
traitement de données de TP RX  

 
 
 
 
 
Igor Pro est un programme puissant de traitement de données scientifiques et de simulations 
numériques. Il permet également de produire des graphes scientifiques de grande qualité. 
 
L’objectif de ce texte est de vous permettre d'apprendre les bases du logiciel et de vous guider 
dans le traitement et l'affichage des données des TP de rayons X.   
  
Si vous avez besoin de plus de détails sur une fonctionnalité, un guide très complet est 
disponible sur les ordinateurs (Menu Démarrer, Tous les programmes, Igor Pro).  
 
La version du logiciel installée dans les salles est Igor Pro 7. 
 
 
Pour vous faciliter certaines tâches (comme par exemple l'importation des données des 
manips) un ensemble de "macros" spécialisées est disponible. Voici les instructions pour les 
installer : 
 
*Sur les pc d’analyse de la plateforme RX, après avoir lancer Igor, vous pourrez charger les 
macros souhaitées (RX ou RMN) via le menu "Analysis > Packages". Par exemple pour 
charger les macros RX cliquez sur "install TP RX ver. 1.00".  Vous verrez alors apparaître un 
nouveau menu "TP RX" dans la barre des menus. 
 
*Si vous ouvrez une session personnelle avec vos identifiants Adonis :   

- lancer Igor  
- cliquer dans le menu du logiciel sur "Misc > Miscellaneous settings > Igor Pro User 

Files" > Change Path, pointer vers "R:\Depart_Phys\Igor Pro 7 User Files", ensuite 
cliquer sur "save" pour sauvegarder la configuration (elle sera permanente, pas besoin 
de refaire cette opération à chaque session),  

- vous devez fermer et relancer Igor pour que ce changement de configuration soit pris en 
compte (le dossier "Igor Pro User Files" sera scanné au démarrage du logiciel). NB. A la 
fermeture, si vous voulez sauvegarder votre fichier "*.pxp", enregistrez celui-ci de 
préférence dans vote espace personnel, le lecteur "P:\". A la réouverture d'Igor, vous 
pourrez charger les macros souhaités (RX ou RMN) via le menu "Analysis > Packages", 
par exemple pour charger les macros RX cliquez sur "install TP RX ver. 1.00".  Vous 
verrez alors apparaître un nouveau menu "TP RX" dans la barre des menus. 

 
Notez que si vous sauvegardez un projet (menu "Save Experiment" créant un fichier "*.pxp") 
qui utilise ces macros, lorsque vous l'ouvrez plus tard ces mêmes macros devraient être 
automatiquement activés (regardez la barre de menus) et dans ce cas il ne faut pas les charger 
à nouveau. 
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Quelques indications pour démarrer en Igor Pro 
 
 
Igor est un logiciel où toutes les actions peuvent être déclenchées à partir de la ligne de 
commande (Command Window), en tapant du code  dans la zone du prompt, exactement 
comme en Matlab.  Cependant, la particularité de Igor est que la plupart des commandes sont 
aussi accessibles via menus et clics de souris: ces menus nous aident à construire une ligne de 
commande de manière interactive. Ainsi, même si on n'a pas besoin de connaître les 
instructions du langage pour des opérations simples, on apprend finalement ces instructions 
assez vite en regardant l'historique des commandes créées pour nous par les actions des 
menus. La fenêtre Historique permet de rappeler rapidement une opération déjà effectuée (en 
la modifiant éventuellement) sans passer par les menus.  

  
 
 
Pour ceux qui ont l'habitude de logiciels comme Excel ou équivalents il y a plusieurs 
différences majeures à retenir avant de se lancer dans Igor: 
 

- Alors qu'en Excel les données sont indissociables des feuilles de calcul, dans Igor les 
données ont leurs propre existence indépendamment qu'elles soient ou non affichées 
dans un tableau. De ce point de vue Igor est beaucoup plus proche d'un environnement 
de programmation comme Matlab.  DataBrowser est, comme son nom indique, un 
outil permettant de parcourir l'ensemble des données créées dans une session.  

- Comme les données sont indépendantes des feuilles qui les affichent, chaque colonne 
de donnée a une longueur (nombre de points) spécifiée.  Si l'on veut pouvoir afficher 
un graph de Y vs X il faut que les colonnes (waves, voir plus loin) X et Y aient la 
même longueur. On peut consulter la taille des waves dans DataBrowser,  et aussi 
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lorsqu'on crée une feuille pour les afficher, où la "fin" de chaque colonne est indiquée 
par une barre grise comme ci-dessous: 
 

  
 

 
- Il n'est pas toujours nécessaire d'avoir une colonne X pour tracer Y vs. X.  En effet, 

Igor se spécialise dans le traitement des données spectroscopiques où les valeurs de 
l'abscisse doivent être régulièrement espacées pour permettre leur traitement 
mathématique (transformée de Fourier etc.).  Pour ce genre de données les colonnes 
d'abscisses sont superflues et seront calculées automatiquement par Igor (NB. ce 
modèle de données n'est pas nécessaire pour traiter les données issues des manips du 
TP RX mais sera utilisé pour les simulations en TP de RMN).  

 
 
 
Fenêtres Igor 
 
Quand on lance Igor deux outils sont déjà ouverts : le Data 
Browser et le Command Window. Si ces outils ne sont pas 
visibles, vous pouvez les ouvrir (Menu Data pour le Data 
Browser, Menu Windows pour le Command Window). 
 
Le menu Windows permet de gérer l'affichage des fenêtres.   
En plus de la fenêtre de commande et de l'Historique, les 
principaux types de fenêtres qu'on peut créer sont: 
 

- les feuilles ("Tables")  permettent de visualiser les 
données en les affichant en colonnes comme sur une 
feuille Excel;  

- les Graphs permettent de faire des tracés; 
- Les "Procédures" sont des pages de code (si on utilise des macros) 

 
 
 
 
Créer des données: généralités 
 
Dans Igor, les données sont stockées dans des « waves », qui sont en gros des tableaux de 
données (colonnes, matrices etc. jusqu’à 4 dimensions) avec quelques informations 
supplémentaires.  Nous nous concentrons pour l’instant sur des waves  unidimensionnelles.  
 
Il y a plusieurs façons de créer des waves: 
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- En important les données d'un fichier (menu Data->Load Waves), 
- en créant une feuille ("Table") et en tapant des valeurs dedans (Igor crée alors des waves 
avec des noms par défaut, comme wave0,wave1 etc., on pourra les modifier plus tard avec 
"Rename"). 
- en créant une feuille et en faisant copier-coller d'une autre colonne ou à partir d'une feuille 
de calcul d'un autre logiciel (par exemple Excel) 
- en créant des waves explicitement avec le menu Data->MakeWaves 
- en faisant une copie d'un wave existant avec le menu Data->DuplicateWaves (l’utilité de 
créer un wave en passant par « Duplicate » est qu'il vous permet de créer un wave ayant le 
même nombre de lignes (et les même "x scaling") que votre wave initial.  
 
Pour importer les données brutes des manips du TP RX on utilisera des macros spécifiques, 
voir ci-dessous.  
 
Importation des données des TP RX 
 
Les données issues des manips de rayons-X sont enregistrées sous forme de fichiers texte 
(extension 'txt' ou 'dat') contenant un en-tête et deux colonnes de données. 
 
Pour importer facilement ces données utilisez les 
macros fournis (la version avec détection 
automatique de format devrait marcher dans la 
plupart des cas, sinon il y a deux autres versions 
suivant le type de manip).  
 
Après un dialogue permettant de sélectionner un 
fichier la macro vous demandera de préciser les noms de waves à créer.   
 
Attention, les noms suggérés par défaut comme  "theta" et "int" ne traduisent pas forcément la 
nature des données présentes dans le fichier (que le programme ignore), par exemple dans un 
montage θ−2θ la première colonne représente l'angle 2θ.  Choisissez de préférence des noms 
avec un préfixe ou suffixe qui identifie le type de mesure ou l'échantillon car vous serez 
amenés à importer plusieurs jeux de données dans le même projet pour les tracer sur un même 
graphe. 
 
Les noms des waves doivent commencer par une lettre, évitez de mettre des espaces dans les 
noms (vous pouvez mettre des "_" à la place). 
 
 
En plus d'avoir créer deux nouvelles 
colonnes (waves) la macro crée aussi une 
nouvelle feuille ("table") où elles sont 
affichées.  
 
Rappelons que les données peuvent exister 
sans être affichées, si par erreur vous fermez la feuille les données qu'elle contenait ne seront 
pas effacées et vous pouvez créer une nouvelle feuille avec le menu Windows=>New Table.  
En fait, les feuilles ne sont nécessaires que lorsque l'on veut modifier les données point par 
point, dans ce TP on utilisera les formules pour transformer les données et les feuilles ne 
serviront que pour  vérifier que les valeurs obtenues sont correctes. 
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Manipulation des données 
 
Dans l'exemple montré sur la figure précédente l'importation d'un fichier a créé deux colonnes 
(waves) appelées  angle_tube1,int_tube1.  Pour tracer les intensités il faut d'abord créer une 
colonne représentant la longueur d'onde qu'on appellera lambda_tube1.  Cette colonne devra 
avoir la même longueur que les deux autres, voici deux méthodes équivalentes pour la créer: 
 
1) En tapant des commandes: 
faites afficher la barre de commandes (Windows->Command Window ou Ctrl-J), ensuite 
tapez: 
duplicate angle_tube1 lambda_tube1 
Cette commande crée une copie angle_tube1 avec un nouveau nom.  
 
2) En faisant copier-coller dans la feuille: 
sélectionnez une des colonnes, ensuite Ctrl-C, 
pointez vers une colonne vide et Ctrl-V. Le 
menu contextuel (bouton droit) vous permet 
ensuite de renommer la nouvelle colonne). 
 
 
Pour attribuer les valeurs à lambda_tube1 en fonction de angle_tube1 on tape simplement la 
formule dans la ligne de commande, donc pour la loi de Bragg on aura quelque chose comme 
 
lambda_tube1 = ...*sin(angle_tube1*...) 
 
Cette formule s'appliquera automatiquement à tous les points du wave cible. 
NB. La fonction sin prend un argument en radians. Pour les conversions notez que Igor 
connaît la constante 'pi'. 
 
Après l'opération la formule apparaitra dans l'historique des commandes. Pour rappeler une 
commande de l'historique (par exemple pour corriger une erreur dans la formule) cliquer 
dessus et lorsqu'elle est sélectionnée taper "Entrée". Une copie de la commande apparaît sur la 
ligne de commande, vous pouvez alors la modifier et l'exécuter en tapant sur Entrée.   
 

Graphes 
 
 
Pour créer un nouveau graphe on utilise le menu 
Windows->New Graph.   
 
On sélectionne les colonnes X et Y et on cique sur 
"Do It". Remarquez que la commande équivalente 
créée par Igor est ici: 
Display int_tube1 vs lambda_tube1 
 
 
 
 
 
 



6  
 

Igor affichera la courbe avec les paramètres par défaut (ligne rouge reliant les points). Pour 
changer le style d'affichage: clic droit sur un point de la courbe, menu contextuel "Modify ...." 
(équivalent au menu Graph=>Modify Trace Appearance). 
On peut ensuite sélectionner le style (ligne, symboles, couleur etc.) pour chacune des courbes 
affichées dans un graphe. 
 

 
 
 
On double-cliquant sur un axe on fait apparaître un menu 
correspondant (figure ci-contre). 
Il sera pratique de choisir un axe logarithmique pour les 
intensités. 
 
 
 
 
 
 
 
 
 
Pour ajouter d'autres tracés sur le même graphe: menu Graph->Add traces to graph. 
 
Les données d'abscisse sont choisies indépendamment pour chaque trace.  
Comme avant, le tracé sera affiché avec des paramètres par défaut et on utilisera le menu 
Modify Trace Appearance pour changer de couleur, style etc. 
 
Sauvegarde  
 
N'oubliez pas de sauvegarder régulièrement votre travail en utilisant le menu File=>Save 
Experiment. Cette commande va enregistrer un fichier 'pxp' contenant tout votre projet: 
données, graphes, historique des commandes etc. et permettra de le restaurer en cas de fausse 
manœuvre (ou de panne de courant).  
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Travailler avec des graphiques: zoom, curseurs, annotations etc.  
 
 
Pour faire un zoom:  
glisser-déplacer pour sélectionner une zone, cliquer 
dans la zone et choisir le type de zoom.  
"shrink" est l'inverse d'un zoom. 
 
 Pour revenir aux pleines échelles: ctrl-A (raccourci 
du menu Graph->Autoscale Axes). 
 
 
Pour déplacer l'ensemble des courbes: 
Mantenir "Alt" enfoncé (la souris prend la forme d'une main) ensuite glisser-déplacer. Les 
axes s'adaptent automatiquement. 
 
Pour faire apparaître les curseurs: 
Menu Graph=>Show Info ou Ctrl-I. Cette 
commande est aussi reprise dans le menu TP 
RX=> activer les curseurs. 
Une fois que la barre des curseurs est affichée vous 
pouvez glisser-déplacer un des curseurs sur une des 
courbes. La barre des curseurs affiche la position 
correspondante (valeurs X et Y). 
 
 
Annotations et légendes 
 
Igor  permet d'ajouter trois type d'annotations (menu Graph => Add Annotation): 
 
 
- un texte quelconque 
- une légende (texte avec les symboles utilisés pour les tracés) 
- un "Tag" : un texte lié à un point d'une courbe avec une flèche. 
 
Les macros fournis permettent de créer automatiquement un "Tag" affichant la valeur de 
l'abscisse (menu TP RX=>marquer l'abscisse du curseur A ...".  Placez le curseur et exécuter 
la macro. Le texte affiché pourra ensuite être amendé (par exemple en ajoutant l'identification 
de la transition etc.) en double-cliquant dessus. 
 
Il existe aussi une macro plaçant trois autres curseurs aux positions correspondant aux 
multiples de l'abscisse du curseur A  (TP RX => montrer les ordres supérieurs"). 
 
 
Pour utiliser des axes différents:  
 
En général dans ce TP toutes les données tracées dans un graphe utiliseront les mêmes axes 
communs: l'axe X pour les longueur d'onde et l'axe Y pour les intensités. 
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Il existe cependant des situations où on aurait besoin de superposer les tracés avec par 
exemple des axes Y indépendants (exemple ci-dessus: montrer le profile d'un filtre Nickel).  
Vous pouvez choisir les axes dans le menu "Append Traces...", figure ci-dessus à gauche.   
 
Documentation 
 
Igor contient un petit éditeur (menu Windows=>New=>Notebook, si vous sélectionnez 
"formatted text" vous pourrez aussi y inclure des graphiques, avec copier-coller). 
L'idée est de permettre de créer des projets auto-documentés: c'est surtout pratique pour noter 
la correspondance entre les noms de données et les manips et noms de fichiers 
correspondants, on vous conseille vivement de vous en servir dans ce but. 
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Annexe 

Références Igor 
 
Format des données 
On considère que les données sont stockées dans un fichier texte sous forme de colonnes. 
Chaque colonne est importée dans Igor sous forme d’une wave 1D. 
 
Importer un fichier en format ASCII (autre que les fichiers RX pour lequels les macros 
existent) 
Data → Load Waves → Load General Text… 
Choisir le fichier. Nommer les colonnes. Chaque colonne sera une wave. 
Dans le cas d’un wave avec valeurs d’abscisse régulières, vous pouvez faire Data → Change Wave 
Scaling… pour définir les valeurs en abscisse. 
 
Visualiser des waves dans un tableau 
Data → Data Browser 
Double-cliquer sur la wave concernée. 
Pour visualiser d’autres waves dans le même tableau : Table → Append Columns to Table 
Autre solution : sélectionner les différentes waves dans le Data Browser, cliquer droit sur la souris 
et sélectionner « Edit »  
 
Changer les valeurs d’une wave à partir d’une formule 
Ctrl-J pour faire apparaitre la ligne de commande (Windows->Command window).  
Note : les noms ne sont pas sensibles aux majuscules. 
 
Exemples :  wave1 = 2*wave2           pour tous les points    

wave1[1,100]= 2*wave2 même chose pour les points 1 à 100  
  wave1= wave2[p+1]       ici [p] est le n° du point 

 … 
Attention : les waves doivent exister avant de pouvoir être utilisées. 
 
Créer un wave 
Data → Make Wave, ou Duplicate Wave 
(L’avantage de l’option Duplicate Wave est qu’elle assure que le nombre de lignes est identique) 
 
Tracer une courbe Y vs X 
Windows → New Graph 
Choisir les waves X et Y. 
Ou choisir Y et « calculated » (dans le cas des valeurs d’abscisse régulièrement espacées) 
 
Ajouter une courbe Y vs X à un graph déjà existant 
Graph → Append Traces to Graph 
 
Tracer une courbe Y1 vs X1, Y2 vs X2 avec deux échelles différentes 
Windows → New Graph 
Cliquer le bouton « more choices » 
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Ajouter des barres d’erreur 
Double-cliquer sur la trace en question. Cocher la case ‘Error bars’. Choisir les barres d’erreurs 
souhaitées. 
 
Manipuler le graphe 
Pour zoomer : Définir une fenêtre avec la souris. Cliquer droite dans la fenêtre prédéfinie puis 
choisir le type de zoom souhaité. 
Revenir en arrière sur le zoom : Ctrl-Z. 
Mettre à l’échelle automatique : Ctrl-A. 
Modifier les propriétés d’une courbe (couleur, épaisseurs…) : Double-cliquer sur la courbe. 
Modifier les propriétés (étiquettes, grilles…) d’un axe : Double-cliquer sur l’axe. 
Mettre une légende automatique : Cliquer droite → Add Annotation… Choisir « Legend ». 
… 
 
Utiliser les curseurs 
Ctrl-I pour faire paraitre des curseurs. Placer les curseurs aux limites des données concernées par 
l’ajustement. 
Un bandeau apparaît sous le graphe avec 2 curseurs. Ils peuvent être placés sur le graphe en 
cliquant-glissant. 

 
 
 
Visualiser tous les graphes en résumé 
Misc → Graph Browser 
 
Pour aller + vite et + loin… 
Toutes ces opérations sont réalisables directement par ligne de commande dans la fenêtre 
« command window » (Ctrl-J).  Vous pouvez vérifier la commande qui s’affiche lors de chaque 
opération. N’hésitez pas à consulter l’aide ou demander à votre enseignant. 
 


	Quelques indications pour démarrer en Igor Pro
	/Fenêtres Igor
	Créer des données: généralités
	Importation des données des TP RX
	Manipulation des données
	/Graphes
	Sauvegarde
	Travailler avec des graphiques: zoom, curseurs, annotations etc.
	Documentation

	Annexe
	Références Igor

